libraries/poco: New maintainer, script improvements
Signed-off-by: Edward W. Koenig <kingbeowulf@linuxgalaxy.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e00824a64f
commit
141fc676bc
|
@ -1,4 +1,12 @@
|
|||
Modern, powerful open source C++ class libraries and
|
||||
frameworks for building network- and internet-based
|
||||
applications that run on desktop, server, mobile and
|
||||
embedded systems.
|
||||
Modern, powerful open source C++ class libraries and frameworks for
|
||||
building network- and internet-based applications that run on desktop,
|
||||
server, mobile and embedded systems.
|
||||
|
||||
PostgreSQL (on Sbo) and libiodbc (part of Slackware) or UnixODBC
|
||||
(on SBo) are optional dependencies that will be automatically picked
|
||||
up during configuration. If you have PostgreSQL installed and want to
|
||||
compile the corresponding database connector, do this:
|
||||
|
||||
POSTGRESQL=yes ./poco.SlackBuild
|
||||
|
||||
|
||||
|
|
|
@ -22,6 +22,8 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# 29-DEC-2022: new maintainer, Edward W. Koenig (kingbeowulf)
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=poco
|
||||
|
@ -47,6 +49,14 @@ if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|||
exit 0
|
||||
fi
|
||||
|
||||
# Make optionally detected components really optional as they are in
|
||||
# CMAKE build configuration upstream.
|
||||
if [ ${POSTGRESQL:-no} = "no" ]; then
|
||||
NOPOSTGRESQL="--omit=Data/PostgreSQL"
|
||||
else
|
||||
NOPOSTGRESQL=""
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
@ -84,10 +94,15 @@ if [ "$ARCH" = "x86_64" ]; then
|
|||
patch -p1 < $CWD/poco_x64.patch
|
||||
fi
|
||||
|
||||
# Slackware ships with MariaDB not MySQL, patch from Arch Linux
|
||||
patch -p1 < $CWD/poco_mariadb.patch
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--no-tests \
|
||||
--no-samples \
|
||||
$NOPOSTGRESQL \
|
||||
--sqlite-thread-safe=2 \
|
||||
--shared
|
||||
|
||||
make
|
||||
|
|
|
@ -5,6 +5,6 @@ DOWNLOAD="https://pocoproject.org/releases/poco-1.12.4/poco-1.12.4-all.tar.gz"
|
|||
MD5SUM="64f39db47d42f2eeec71dabfdbc6dce3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="unixODBC postgresql"
|
||||
MAINTAINER="Dimitris Zlatanidis"
|
||||
EMAIL="d.zlatanidis@gmail.com"
|
||||
REQUIRES=""
|
||||
MAINTAINER="Edward W. Koenig"
|
||||
EMAIL="kingbeowulf@linuxgalaxy.org"
|
||||
|
|
|
@ -0,0 +1,32 @@
|
|||
--- /library/slackware/SBo_repository/SBo/libraries/poco/poco.SlackBuild 2022-12-01 16:48:10.265823314 -0800
|
||||
+++ poco.SlackBuild 2022-12-28 20:11:48.439588528 -0800
|
||||
@@ -47,6 +47,14 @@
|
||||
exit 0
|
||||
fi
|
||||
|
||||
+# Make optionally detected components really optional as they are in
|
||||
+# CMAKE build configuration upstream.
|
||||
+if [ ${POSTGRESQL:-no} = "no" ]; then
|
||||
+ NOPOSTGRESQL="--omit=Data/PostgreSQL"
|
||||
+else
|
||||
+ NOPOSTGRESQL=""
|
||||
+fi
|
||||
+
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
@@ -84,10 +92,14 @@
|
||||
patch -p1 < $CWD/poco_x64.patch
|
||||
fi
|
||||
|
||||
+# Slackware ships with MariaDB not MySQL, patch from Arch Linux
|
||||
+patch -p1 < $CWD/poco_mariadb.patch
|
||||
+
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--no-tests \
|
||||
--no-samples \
|
||||
+ $NOPOSTGRESQL \
|
||||
--shared
|
||||
|
||||
make
|
|
@ -0,0 +1,12 @@
|
|||
diff -uNr poco/Data/MySQL/CMakeLists.txt poco_changed/Data/MySQL/CMakeLists.txt
|
||||
--- poco/Data/MySQL/CMakeLists.txt 2021-06-28 12:16:01.000000000 +0200
|
||||
+++ poco_changed/Data/MySQL/CMakeLists.txt 2021-10-14 14:53:52.605311071 +0200
|
||||
@@ -21,7 +21,7 @@
|
||||
DEFINE_SYMBOL MySQL_EXPORTS
|
||||
)
|
||||
|
||||
-target_link_libraries(DataMySQL PUBLIC Poco::Data MySQL::client)
|
||||
+target_link_libraries(DataMySQL PUBLIC Poco::Data mariadb)
|
||||
target_include_directories(DataMySQL
|
||||
PUBLIC
|
||||
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
|
Loading…
Reference in New Issue