system/tiger: Updated build and added patch.

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
Menno Duursma 2010-09-10 21:19:15 -04:00 committed by dsomero
parent d6615ee8e4
commit 11d1d4b150
5 changed files with 74 additions and 10 deletions

View File

@ -0,0 +1,9 @@
#
# Regular cron jobs for the tiger package
#
# Configuration file
DEFAULT=/etc/default/tiger
# default setting, overriden in the above file
NICETIGER=10
#
0 * * * * root test -x /usr/sbin/tigercron && { [ -r "$DEFAULT" ] && . "$DEFAULT" ; nice -n$NICETIGER /usr/sbin/tigercron -q ; }

View File

@ -0,0 +1,31 @@
Login ID nobody is disabled, but still has a valid shell \(/bin/sh\)
Login ID mail's home directory \(/var/mail\) has group `mail' write access.
Login ID \w+'s parent directory \(/home\) has group `staff' write access.
Log file /var/log/wtmp permission should be 644
Log file /var/log/btmp does not exist
Log file /var/run/utmp permission should be 644
Log file /var/log/loginlog does not exist
Log file /var/log/messages permission should be 640
The owner of /var/log/wtmp should be root (owned by utmp).
/var/log/wtmp should not have group write.
The owner of /var/run/utmp should be root (owned by utmp).
/var/run/utmp should not have group write.
/var/log/XFree86.0.log should not have world read.
/etc/fstab should not have group read.
/etc/fstab should not have world read.
/etc/inetd.conf should not have group read.
/etc/inetd.conf should not have world read.
/etc/pam.d/sudo should not have world read.
The directory /dev/ataraid resides in a device directory.
The directory /dev/cciss resides in a device directory.
The directory /dev/fd resides in a device directory.
The directory /dev/input resides in a device directory.
The directory /dev/pts resides in a device directory.
The directory /dev/rd resides in a device directory.
The directory /dev/usb resides in a device directory.
The directory /dev/ida resides in a device directory.
/dev/null has world permissions
/dev/ptmx has world permissions
/dev/gpmctl has world permissions
/dev/gpmdata has world permissions
File ".fetchmail-UIDL-cache" in the mail spool, owned by "fetchmail".

View File

@ -0,0 +1,18 @@
diff -ur tiger-3.2.3/util/genmsgidx tiger-3.2.3.new/util/genmsgidx
--- tiger-3.2.3/util/genmsgidx 2008-11-27 23:34:21.000000000 +0100
+++ tiger-3.2.3.new/util/genmsgidx 2010-09-01 12:43:22.000000000 +0200
@@ -96,10 +96,10 @@
haveallof variables BASEDIR || exit 1
# Clear idx file and detect error
-> $BASEDIR/doc/explain.idx && {
- echo "Error: Cannot write over the index file $BASEDIR/doc/explain.idx. Aborting"
- exit 1
-}
+#> $BASEDIR/doc/explain.idx && {
+# echo "Error: Cannot write over the index file $BASEDIR/doc/explain.idx. Aborting"
+# exit 1
+#}
$LS $BASEDIR/doc/*.txt |
while read infile

View File

@ -10,7 +10,7 @@
PRGNAM=tiger
VERSION=${VERSION:-3.2.3}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@ -57,6 +57,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# The build errs on this
patch --verbose -p1 < $CWD/patches/tiger-3.2.3-build-fix.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS"
export CFLAGS CXXFLAGS
@ -76,15 +79,15 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
install -D -m 0644 debian/cron.d $PKG/etc/cron.d/tiger.new
install -D -m 0640 debian/debian.ignore $PKG/etc/tiger/tiger.ignore.new
install -D -m 0644 $CWD/config/tiger.cron $PKG/etc/cron.d/tiger.new
install -D -m 0640 $CWD/config/tiger.ignore $PKG/etc/tiger/tiger.ignore.new
# From the .spec: 3.- This should be done by the Makefile, grumble...
install -D -m 0644 version.h $PKG/usr/lib/tiger/version.h
# Remove unnecesary stuff
( cd $PKG
for system in AIX HPUX IRIX NeXT SunOS UNICOS UNICOSMK Tru64 MacOSX ; do
for system in AIX HPUX IRIX NeXT SunOS UNICOS UNICOSMK Tru64 MacOSX ; do
rm -rf ./usr/libexec/tiger/systems/$system
done
find . -type d -name CVS | xargs -iX rm -rf "X"
@ -95,17 +98,20 @@ install -D -m 0644 version.h $PKG/usr/lib/tiger/version.h
mv -v tigerrc tigerrc.new
)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [A-Z][A-Z]* site-* tigerrc* $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [A-Z][A-Z]* site-* tigerrc* \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a other/cert-usc20.txt contrib/fix_tiger_GROUPS.sh \
$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/txt
cp $PKG/usr/libexec/tiger/doc/*.txt $PKG/usr/doc/$PRGNAM-$VERSION/txt
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
cp $PKG/usr/libexec/tiger/html/*.html $PKG/usr/doc/$PRGNAM-$VERSION/html
# Delete the redundant stuff
rm -rf $PKG/usr/libexec/tiger/doc $PKG/usr/libexec/tiger/html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View File

@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Menno Duursma"
EMAIL="druiloor@zonnet.nl"
APPROVED="rworkman"
APPROVED="dsomero"