network/xinetd: Updated for version 2.3.15.4, upstream changed.
This commit is contained in:
parent
2993bbf3dc
commit
0bd54b4ba4
|
@ -7,6 +7,7 @@ config() {
|
|||
rm $NEW
|
||||
fi
|
||||
}
|
||||
|
||||
preserve_perms() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
|
@ -17,18 +18,19 @@ preserve_perms() {
|
|||
fi
|
||||
config $NEW
|
||||
}
|
||||
config etc/xinetd.conf.new
|
||||
config etc/xinetd.d/chargen-dgram.new
|
||||
config etc/xinetd.d/chargen-stream.new
|
||||
config etc/xinetd.d/daytime-dgram.new
|
||||
config etc/xinetd.d/daytime-stream.new
|
||||
config etc/xinetd.d/discard-dgram.new
|
||||
config etc/xinetd.d/discard-stream.new
|
||||
config etc/xinetd.d/echo-dgram.new
|
||||
config etc/xinetd.d/echo-stream.new
|
||||
config etc/xinetd.d/ftp-sensor.new
|
||||
config etc/xinetd.d/tcpmux-server.new
|
||||
config etc/xinetd.d/time-dgram.new
|
||||
config etc/xinetd.d/time-stream.new
|
||||
preserve_perms etc/rc.d/rc.xinetd.new
|
||||
|
||||
config etc/xinetd.conf.new
|
||||
config etc/xinetd.d/chargen.new
|
||||
config etc/xinetd.d/chargen-udp.new
|
||||
config etc/xinetd.d/daytime.new
|
||||
config etc/xinetd.d/daytime-udp.new
|
||||
config etc/xinetd.d/discard.new
|
||||
config etc/xinetd.d/discard-udp.new
|
||||
config etc/xinetd.d/echo.new
|
||||
config etc/xinetd.d/echo-udp.new
|
||||
config etc/xinetd.d/servers.new
|
||||
config etc/xinetd.d/services.new
|
||||
config etc/xinetd.d/time.new
|
||||
config etc/xinetd.d/time-udp.new
|
||||
|
||||
preserve_perms etc/rc.d/rc.xinetd.new
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
diff -Nur xinetd-2.3.14.orig//Makefile.in xinetd-2.3.14/Makefile.in
|
||||
--- xinetd-2.3.14.orig//Makefile.in 2003-08-15 09:00:45.000000000 -0500
|
||||
+++ xinetd-2.3.14/Makefile.in 2010-11-24 23:45:57.615587280 -0600
|
||||
@@ -75,27 +75,27 @@
|
||||
|
||||
install: build
|
||||
for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
|
||||
- test -d $$i || mkdir -p $$i ; done
|
||||
- $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
|
||||
- $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
|
||||
- $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
|
||||
- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
|
||||
+ test -d $(DESTDIR)/$$i || mkdir -p $(DESTDIR)/$$i ; done
|
||||
+ $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)/$(DAEMONDIR)
|
||||
+ $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)/$(DAEMONDIR)
|
||||
+ $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)/$(DAEMONDIR)
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)/$(MANDIR)/man5/xinetd.conf.5
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)/$(MANDIR)/man8/xinetd.log.8
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)/$(MANDIR)/man8/xinetd.8
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)/$(MANDIR)/man8/itox.8
|
||||
+ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)/$(MANDIR)/man8/xconv.pl.8
|
||||
@echo "You must put your xinetd.conf in /etc/xinetd.conf"
|
||||
@echo "There is a sample config file in xinetd/sample.conf and you can"
|
||||
@echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
|
||||
|
||||
uninstall:
|
||||
- rm -f $(DAEMONDIR)/xinetd
|
||||
- rm -f $(DAEMONDIR)/itox
|
||||
- rm -f $(DAEMONDIR)/xconv.pl
|
||||
- rm -f $(MANDIR)/man5/xinetd.conf.5
|
||||
- rm -f $(MANDIR)/man8/xinetd.log.8
|
||||
- rm -f $(MANDIR)/man8/xinetd.8
|
||||
- rm -f $(MANDIR)/man8/itox.8
|
||||
+ rm -f $(DESTDIR)/$(DAEMONDIR)/xinetd
|
||||
+ rm -f $(DESTDIR)/$(DAEMONDIR)/itox
|
||||
+ rm -f $(DESTDIR)/$(DAEMONDIR)/xconv.pl
|
||||
+ rm -f $(DESTDIR)/$(MANDIR)/man5/xinetd.conf.5
|
||||
+ rm -f $(DESTDIR)/$(MANDIR)/man8/xinetd.log.8
|
||||
+ rm -f $(DESTDIR)/$(MANDIR)/man8/xinetd.8
|
||||
+ rm -f $(DESTDIR)/$(MANDIR)/man8/itox.8
|
||||
|
||||
distclean: clean
|
||||
rm -f config.cache config.log Makefile config.status xinetd/itox
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
|
||||
# Copyright 2012 Chris Abela, Malta
|
||||
# Copyright 2014 Ryan P.C. McQuen, WA, ryanpcmcquen@member.fsf.org
|
||||
# Copyright 2017 Aaditya Bagga <aaditya_gnulinux@zoho.com>
|
||||
# Copyright 2017-2019 Aaditya Bagga <aaditya_gnulinux@zoho.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,13 +25,10 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=xinetd
|
||||
VERSION=${VERSION:-2.3.15}
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=${VERSION:-2.3.15.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
DL_PRGNAM=$PRGNAM-$PRGNAM
|
||||
DL_VERSION=${DL_VERSION:-2-3-15}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
|
@ -64,9 +61,9 @@ set -e
|
|||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $DL_PRGNAM-$DL_VERSION
|
||||
tar xvf $CWD/$PRGNAM-$DL_VERSION.tar.gz || tar xvf $CWD/$DL_PRGNAM-$DL_VERSION.tar.gz
|
||||
cd $DL_PRGNAM-$DL_VERSION
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
|
||||
find -L . \
|
||||
|
@ -75,8 +72,7 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Add DESTDIR support
|
||||
patch -p1 < $CWD/xinetd-add_destdir.patch
|
||||
./autogen.sh
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -93,18 +89,17 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
# Install config files
|
||||
mkdir -p $PKG/etc/xinetd.d/
|
||||
cat contrib/xinetd.conf > $PKG/etc/xinetd.conf.new
|
||||
for file in contrib/xinetd.d/* ; do
|
||||
cat $file > $PKG/etc/xinetd.d/$(basename $file).new ;
|
||||
done
|
||||
|
||||
# Install the Slackware init script
|
||||
mkdir -p $PKG/etc/rc.d
|
||||
cat $CWD/rc.xinetd > $PKG/etc/rc.d/rc.xinetd.new
|
||||
chmod 0755 $PKG/etc/rc.d/rc.xinetd.new
|
||||
|
||||
# Backup config files
|
||||
mv "$PKG/etc/xinetd.conf" "$PKG/etc/xinetd.conf.new"
|
||||
for file in "$PKG"/etc/xinetd.d/*; do
|
||||
mv "${file}" "${file}.new"
|
||||
done
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
|
@ -113,7 +108,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
|
|||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
AUDIT CHANGELOG COPYRIGHT INSTALL README TODO contrib \
|
||||
CHANGELOG COPYRIGHT README.md \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
@ -123,4 +118,3 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
|||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="xinetd"
|
||||
VERSION="2.3.15"
|
||||
HOMEPAGE="https://github.com/xinetd-org/xinetd"
|
||||
DOWNLOAD="https://github.com/xinetd-org/xinetd/archive/xinetd-2-3-15.tar.gz"
|
||||
MD5SUM="dbd435d2bc822ea4566dd18632c09379"
|
||||
VERSION="2.3.15.4"
|
||||
HOMEPAGE="https://github.com/openSUSE/xinetd"
|
||||
DOWNLOAD="https://github.com/openSUSE/xinetd/archive/2.3.15.4.tar.gz"
|
||||
MD5SUM="c2ca87367a7017a8f736a32e18be38e5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in New Issue