libraries/Hypodermic: Added (IoC container for C++).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Andre Barboza 2017-02-09 08:50:07 +07:00 committed by Willy Sudiarto Raharjo
parent 6e2a853b06
commit 0b55a809ea
5 changed files with 155 additions and 0 deletions

View File

@ -0,0 +1,97 @@
#!/bin/sh
# Slackware build script for Hypodermic
# Copyright 2017 Andre Barboza, Belo Horizonte - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Hypodermic
VERSION=${VERSION:-2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/Hypodermic.patch
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="Hypodermic"
VERSION="2.1"
HOMEPAGE="https://github.com/ybainier/Hypodermic"
DOWNLOAD="https://github.com/ybainier/Hypodermic/archive/v2.1/Hypodermic-v2.1.tar.gz"
MD5SUM="5760d300829cf89b93f1c4e25a7b1f5c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Andre Barboza"
EMAIL="bmg.andre@gmail.com"

View File

@ -0,0 +1,13 @@
diff -ur Hypodermic-2.1.old/Hypodermic/CMakeLists.txt Hypodermic-2.1/Hypodermic/CMakeLists.txt
--- Hypodermic-2.1.old/Hypodermic/CMakeLists.txt 2016-09-23 10:59:34.000000000 -0300
+++ Hypodermic-2.1/Hypodermic/CMakeLists.txt 2017-02-08 22:22:43.345091596 -0200
@@ -109,7 +109,7 @@
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/libhypodermic.pc
- DESTINATION lib/pkgconfig
+ DESTINATION lib${LIB_SUFFIX}/pkgconfig
)
Only in Hypodermic-2.1.old/: build

View File

@ -0,0 +1,16 @@
Hypodermic was started with the will to mimic the famous .NET Autofac.
Although its design evolved, both its behavior and its expressiveness
tend to remain the same.
Features:
- Header only
- Developer friendly compilation errors
- Easy to use out of the box
- Configurable instance lifetime
- On the fly registrations
- Constructor discovery
- Merge-able registrations
- Dependencies can be particular for a specific type
- Injectable vector of types
- Injectable factories of types
- Injectable container

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
Hypodermic: Hypodermic (IoC container for C++)
Hypodermic:
Hypodermic: Hypodermic was started with the will to mimic the famous .NET Autofac.
Hypodermic: Although its design evolved, both its behavior and its expressiveness
Hypodermic: tend to remain the same.
Hypodermic:
Hypodermic:
Hypodermic:
Hypodermic:
Hypodermic: https://github.com/ybainier/Hypodermic
Hypodermic: