libraries/OpenSceneGraph: Fix build when asio is installed.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
763d78b279
commit
05d451f233
|
@ -65,9 +65,19 @@ cd $PRGNAM-$PRGNAM-$VERSION
|
|||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
-o -perm 511 \) -exec chmod 755 {} \+ -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
|
||||
|
||||
# 20220215 bkw: asio is an optional, auto-detected dependency. Our
|
||||
# version of asio is either too new or too old for this. Note
|
||||
# that this is Asio (the network library for C++), not
|
||||
# ASIO (the Windows low-latency audio API) nor wineasio, nor
|
||||
# /usr/include/boost/asio.hpp, whatever that even is. I don't see a
|
||||
# way to disable asio support via a cmake variable, so it has to be
|
||||
# surgery. Applying this patch disables the RestHttpDevice plugin,
|
||||
# hope that's OK.
|
||||
patch -p1 < $CWD/disable_asio.diff
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
diff -Naur OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt OpenSceneGraph-OpenSceneGraph-3.6.5.patched/CMakeLists.txt
|
||||
--- OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt 2020-01-31 06:03:07.000000000 -0500
|
||||
+++ OpenSceneGraph-OpenSceneGraph-3.6.5.patched/CMakeLists.txt 2022-02-15 01:01:02.259927943 -0500
|
||||
@@ -763,9 +763,6 @@
|
||||
FIND_PACKAGE(GtkGl)
|
||||
FIND_PACKAGE(DirectInput)
|
||||
FIND_PACKAGE(NVTT)
|
||||
- IF (NOT WIN32)
|
||||
- FIND_PACKAGE(Asio)
|
||||
- ENDIF()
|
||||
FIND_PACKAGE(ZeroConf)
|
||||
|
||||
FIND_PACKAGE(LIBLAS)
|
Loading…
Reference in New Issue