desktop/dwm: Added to 12.2 repository
This commit is contained in:
parent
cc1a947b2a
commit
045acf5134
|
@ -0,0 +1,24 @@
|
|||
dwm is a dynamic window manager for X. It manages windows in tiled and
|
||||
floating layouts. Either layout can be applied dynamically, optimizing
|
||||
the environment for the application in use and the task performed. It
|
||||
is the little brother of wmii.
|
||||
|
||||
In tiled layout, windows are managed in a master and stacking area.
|
||||
The master area contains the windows which currently need most
|
||||
attention, whereas the stacking area contains all other windows. In
|
||||
floating layout, windows can be resized and moved freely. Dialog
|
||||
windows are always managed floating, regardless of the layout
|
||||
selected.
|
||||
|
||||
Windows are grouped by tags. Each window can be tagged with one or
|
||||
multiple tags. Selecting certain tags displays all windows with those
|
||||
tags.
|
||||
|
||||
dwm contains a small status bar which displays all available tags, the
|
||||
layout, the title of the focused window, and the text read from the
|
||||
name of the root window. The selected tags are highlighted with a
|
||||
different color, while the tags of the focused window are highlighted
|
||||
with a small point.
|
||||
|
||||
dwm draws a small border around windows to indicate their focus state.
|
||||
|
|
@ -0,0 +1,24 @@
|
|||
CUSTOMIZATION
|
||||
-------------
|
||||
Place patches in patches/ . Any files in this directory will be
|
||||
applied before the build. If you wish to make changes to the default
|
||||
keybindings or other settings, produce a patch against config.h.
|
||||
config.h is a copy of config.def.h distributed with the source
|
||||
tarball.
|
||||
|
||||
Place any patches in the patches/ directory before starting the
|
||||
SlackBuild script.
|
||||
|
||||
Example:
|
||||
|
||||
$ cd dwm-5.5
|
||||
$ cp config.def.h config.h
|
||||
$ vi config.h
|
||||
[make customizations]
|
||||
$ diff -u config.h config.def.h >> ../patches/config.patch
|
||||
$ cd ..
|
||||
$ sh dwm.SlackBuild
|
||||
|
||||
|
||||
|
||||
|
|
@ -0,0 +1,103 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for dwm
|
||||
|
||||
# Written by Tom Canich <tcanich@canich.net>
|
||||
# Released under the BSD
|
||||
# Copyright (c) 2009, Tom Canich, State College, Pennsylvania, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions
|
||||
# are met:
|
||||
# * Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# * Redistributions in binary form must reproduce the above
|
||||
# copyright notice, this list of conditions and the following
|
||||
# disclaimer in the documentation and/or other materials
|
||||
# provided with the distribution.
|
||||
# * Neither the name of Tom Canich nor the names of other
|
||||
# contributors may be used to endorse or promote
|
||||
# products
|
||||
# derived from this software without specific prior
|
||||
# written
|
||||
# permission.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY Tom Canich ''AS IS'' AND ANY
|
||||
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||
# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
|
||||
# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL Tom Canich BE LIABLE FOR
|
||||
# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
|
||||
# CONSEQUENTIAL
|
||||
# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
|
||||
# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
|
||||
# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
|
||||
# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
|
||||
# IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
# Modified by the SlackBuilds.org project
|
||||
|
||||
|
||||
PRGNAM=dwm
|
||||
VERSION=${VERSION:-5.5}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
INSTALL="/bin/ginstall -o root -g root"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
|
||||
for i in `ls $CWD/patches`; do
|
||||
echo "Applying patch $i"
|
||||
patch -p0 < $CWD/patches/$i
|
||||
done
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
make PREFIX=/usr
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp $CWD/README* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -r $CWD/patches $PKG/usr/doc/$PRGNAM-$VERSION/patches
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="dwm"
|
||||
VERSION="5.5"
|
||||
HOMEPAGE="http://dwm.suckless.org"
|
||||
DOWNLOAD="http://code.suckless.org/dl/dwm/dwm-5.5.tar.gz"
|
||||
MD5SUM="352d952e839ab0e2df0b0959a250b098"
|
||||
MAINTAINER="Tom Canich"
|
||||
EMAIL="tcanich@canich.net"
|
||||
APPROVED="chess"
|
|
@ -0,0 +1,13 @@
|
|||
--- config.mk.orig 2009-04-20 20:25:24.000000000 -0400
|
||||
+++ config.mk 2009-04-20 20:25:38.000000000 -0400
|
||||
@@ -4,8 +4,8 @@
|
||||
# Customize below to fit your system
|
||||
|
||||
# paths
|
||||
-PREFIX = /usr/local
|
||||
-MANPREFIX = ${PREFIX}/share/man
|
||||
+PREFIX = /usr
|
||||
+MANPREFIX = ${PREFIX}/man
|
||||
|
||||
X11INC = /usr/X11R6/include
|
||||
X11LIB = /usr/X11R6/lib
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
dwm: dwm (suckless dynamic window manager)
|
||||
dwm:
|
||||
dwm: dwm is a dynamic window manager for X. It manages windows in tiled
|
||||
dwm: and floating layouts. Either layout can be applied dynamically,
|
||||
dwm: optimizing the environment for the application in use and the task
|
||||
dwm: performed. It is the little brother of wmii.
|
||||
dwm: In tiled layout, windows are managed in a master and stacking area.
|
||||
dwm: The master area contains the windows which currently need most
|
||||
dwm: attention, whereas the stacking area contains all other windows.
|
||||
dwm:
|
||||
dwm: Homepage: http://dwm.suckless.org
|
Loading…
Reference in New Issue