libraries/wxWidgets: Updated for version 3.2.1.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2022-10-02 16:07:35 +07:00
parent e75f3dbf02
commit 02f3d1194c
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
4 changed files with 7 additions and 105 deletions

View File

@ -1,56 +0,0 @@
From 600bf54a06a0f11fdfa2e2c2607d586446363a26 Mon Sep 17 00:00:00 2001
From: Maarten Bent <MaartenBent@users.noreply.github.com>
Date: Tue, 19 Jul 2022 17:52:39 +0200
Subject: [PATCH] Use DESTDIR when creating symlinks in CMake install
Prepend $ENV{DESTDIR}, sufficiently escaped to delay its expansion until
the execution of "cmake -E create_symlink" command, to the command path
arguments.
Closes #22653.
See #22610.
---
build/cmake/install.cmake | 2 +-
build/cmake/utils/CMakeLists.txt | 7 ++++---
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/build/cmake/install.cmake b/build/cmake/install.cmake
index 020fa860a2e9..384c6837b814 100644
--- a/build/cmake/install.cmake
+++ b/build/cmake/install.cmake
@@ -43,7 +43,7 @@ else()
install(CODE "execute_process( \
COMMAND ${CMAKE_COMMAND} -E create_symlink \
\"${CMAKE_INSTALL_PREFIX}/lib/wx/config/${wxBUILD_FILE_ID}\" \
- \"${CMAKE_INSTALL_PREFIX}/bin/wx-config\" \
+ \"\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/bin/wx-config\" \
)"
)
endif()
diff --git a/build/cmake/utils/CMakeLists.txt b/build/cmake/utils/CMakeLists.txt
index dbfedec79f75..dbed8cc9b3bb 100644
--- a/build/cmake/utils/CMakeLists.txt
+++ b/build/cmake/utils/CMakeLists.txt
@@ -30,17 +30,18 @@ if(wxUSE_XRC)
BUNDLE DESTINATION "bin"
)
- if(NOT WIN32_MSVC_NAMING)
+ if(NOT WIN32_MSVC_NAMING AND wxBUILD_INSTALL)
if(IPHONE)
set(EXE_SUFFIX ".app")
else()
set(EXE_SUFFIX ${CMAKE_EXECUTABLE_SUFFIX})
endif()
- wx_install(CODE "execute_process( \
+ # Don't use wx_install() here to preserve escaping.
+ install(CODE "execute_process( \
COMMAND ${CMAKE_COMMAND} -E create_symlink \
\"${CMAKE_INSTALL_PREFIX}/bin/${wxrc_output_name}${EXE_SUFFIX}\" \
- \"${CMAKE_INSTALL_PREFIX}/bin/wxrc${EXE_SUFFIX}\" \
+ \"\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/bin/wxrc${EXE_SUFFIX}\" \
)"
)
endif()

View File

@ -1,41 +0,0 @@
From e4f230a3e18ca8d8a1a68d609d206a1191055c93 Mon Sep 17 00:00:00 2001
From: Maarten Bent <MaartenBent@users.noreply.github.com>
Date: Fri, 22 Jul 2022 00:05:42 +0200
Subject: [PATCH] CMake: Support spaces in install path with symlinks
Add quotes around the paths so they are treated as one argument.
---
build/cmake/install.cmake | 4 ++--
build/cmake/utils/CMakeLists.txt | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/build/cmake/install.cmake b/build/cmake/install.cmake
index 9a2ce91d7f5e..020fa860a2e9 100644
--- a/build/cmake/install.cmake
+++ b/build/cmake/install.cmake
@@ -42,8 +42,8 @@ else()
install(DIRECTORY DESTINATION "bin")
install(CODE "execute_process( \
COMMAND ${CMAKE_COMMAND} -E create_symlink \
- ${CMAKE_INSTALL_PREFIX}/lib/wx/config/${wxBUILD_FILE_ID} \
- ${CMAKE_INSTALL_PREFIX}/bin/wx-config \
+ \"${CMAKE_INSTALL_PREFIX}/lib/wx/config/${wxBUILD_FILE_ID}\" \
+ \"${CMAKE_INSTALL_PREFIX}/bin/wx-config\" \
)"
)
endif()
diff --git a/build/cmake/utils/CMakeLists.txt b/build/cmake/utils/CMakeLists.txt
index 47bca6f34a91..dbfedec79f75 100644
--- a/build/cmake/utils/CMakeLists.txt
+++ b/build/cmake/utils/CMakeLists.txt
@@ -39,8 +39,8 @@ if(wxUSE_XRC)
wx_install(CODE "execute_process( \
COMMAND ${CMAKE_COMMAND} -E create_symlink \
- ${CMAKE_INSTALL_PREFIX}/bin/${wxrc_output_name}${EXE_SUFFIX} \
- ${CMAKE_INSTALL_PREFIX}/bin/wxrc${EXE_SUFFIX} \
+ \"${CMAKE_INSTALL_PREFIX}/bin/${wxrc_output_name}${EXE_SUFFIX}\" \
+ \"${CMAKE_INSTALL_PREFIX}/bin/wxrc${EXE_SUFFIX}\" \
)"
)
endif()

View File

@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wxWidgets
VERSION=${VERSION:-3.2.0}
VERSION=${VERSION:-3.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -91,15 +91,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
#Official upstream patches to fix DESTDIR
patch -p1 < $CWD/e4f230a.patch
patch -p1 < $CWD/600bf54.patch
#Fix wx-config to return the correct path
if [ "$LIBDIRSUFFIX" != "" ]; then
sed -i "89s/\/lib/\/lib${LIBDIRSUFFIX}/" $TMP/$PRGNAM-$VERSION/build/cmake/config.cmake
fi
if [ -z "$INTERFACE" ]; then
cmake -B build-gtk3 \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
@ -122,6 +119,7 @@ cmake -B build-gtk3 \
cmake --build build-gtk3
DESTDIR="$PKG" cmake --install build-gtk3
elif [ "${INTERFACE:-gtk3}" = "qt" ]; then
cmake -B build-qt5 \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
@ -143,6 +141,7 @@ cmake -B build-qt5 \
-DCMAKE_BUILD_TYPE=Release .
cmake --build build-qt5
DESTDIR="$PKG" cmake --install build-qt5
fi
#Move librarys to their correct location and fix pkgconfig
if [ "$LIBDIRSUFFIX" != "" ]; then

View File

@ -1,8 +1,8 @@
PRGNAM="wxWidgets"
VERSION="3.2.0"
VERSION="3.2.1"
HOMEPAGE="http://www.wxwidgets.org"
DOWNLOAD="https://github.com/wxWidgets/wxWidgets/archive/v3.2.0/wxWidgets-3.2.0.tar.gz"
MD5SUM="36d186f4b6d4f6fefd794d65970c6658"
DOWNLOAD="https://github.com/wxWidgets/wxWidgets/archive/v3.2.1/wxWidgets-3.2.1.tar.gz"
MD5SUM="813cf3409010e9a1ef36d2ee3fde0f3e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libmspack"