multimedia/flowblade: Updated for version 0.18.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Klaatu 2015-06-13 16:46:38 +07:00 committed by Willy Sudiarto Raharjo
parent 97d7029843
commit 02c57ec122
4 changed files with 8 additions and 60 deletions

View File

@ -14,8 +14,3 @@ splits, but may be slower when programs contain complex composites
unless correct work flow is followed.
Optional recommended dependencies are swh-plugins and calf.
NOTE:
This SlackBuild patches out a dependency on the gnomevfs Python
module for mimetype detection: we use built-in Python tools instead.
This patch has been submitted upstream and is under review for inclusion.

View File

@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for flowblade
# Copyright 2013 klaatu @member.fsf.org
# Copyright 2015 klaatu @member.fsf.org
# GNU All-Permissive License
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@ -9,7 +9,7 @@
# without any warranty.
PRGNAM=flowblade
VERSION=${VERSION:-0.10.0}
VERSION=${VERSION:-0.18}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -48,8 +48,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
tar xvf $CWD/v"$VERSION".tar.gz
cd $PRGNAM-$VERSION/$PRGNAM-trunk
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -57,10 +57,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# patch out gnomevfs dependency
# prefer urllib + mimetypes
patch -p1 ./Flowblade/sequence.py < $CWD/gnomevfs.patch
# install
python setup.py install --root=$PKG

View File

@ -1,8 +1,8 @@
PRGNAM="flowblade"
VERSION="0.10.0"
HOMEPAGE="https://code.google.com/p/flowblade/"
DOWNLOAD="https://flowblade.googlecode.com/files/flowblade-0.10.0.tar.gz"
MD5SUM="322b54beab8db142787a6d508528b1e7"
VERSION="0.18"
HOMEPAGE="https://github.com/jliljebl/flowblade/"
DOWNLOAD="https://github.com/jliljebl/flowblade/archive/v0.18.tar.gz"
MD5SUM="42f9b18020455c81aa15545469acdf96"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="cairomm ffmpeg frei0r gnome-python ladspa_sdk mlt"

View File

@ -1,43 +0,0 @@
--- ./flowblade-0.10.0/Flowblade/sequence.py 2013-09-14 09:49:39.000000000 -0400
+++ sequence.py 2013-11-28 22:34:02.454226123 -0500
@@ -24,7 +24,7 @@
"""
import copy
-import gnomevfs
+import urllib, mimetypes
import mlt
import time #added when testing
import types
@@ -914,8 +914,13 @@
"""
Returns media type of file.
"""
+ # using urllib and mimetype for non gnome environments
try:
- mime_type = gnomevfs.get_mime_type(file_path)
+ url = urllib.pathname2url(file_path)
+ mime_guess = mimetypes.guess_type(url)
+ mime_string = mime_guess[0]
+ mime_type = str.split(mime_string, "/")
+
except Exception, err:
if not os.path.exists(file_path):
# We're doing a heuristic here to identify image sequence file_paths.
@@ -932,13 +937,13 @@
else:
return UNKNOWN
- if mime_type.startswith("video"):
+ if mime_type[0] == "video":
return VIDEO
- if mime_type.startswith("audio"):
+ if mime_type[0] == "audio":
return AUDIO
- if mime_type.startswith("image"):
+ if mime_type[0] == "image":
return IMAGE
return UNKNOWN